Had to share a recent story with my fellow Tige Owners.

My family and I decided to start the season early and trailered our boat down to Lake Travis, TX from Overland Park, KS. Long tow but totally worth it. We launched the boat Sunday March 15th and got all ready to get our first sets in of the season. Got my daughter up and oh my god the GSA plates didn't do anything. We have a very early build 2020 25ZX. We checked fuses and corrected everything that we could find. I immediately called Jeff and Joe at Performance Marine Lake of the Ozarks. They walked through the fuses with us and got us into demo mode at the dock. They also got in touch with Justin at Tige in Abilene. He figured out the issue in about 5 seconds. We had a 40 amp breaker as we were an early build and they switched that to an 80amp breaker. We got extra fuses and it kept blowing. Justin walked us through a temporary band aid where we bypassed the fuse that was blowing and boom tabs worked fine. He told us use the boat and I'll be there tomorrow with the proper fix.

Justin drove all the way from Abilene to fix our boat at the dock on Lake Travis. We couldn't thank him and Tige enough for going way out of their way to make our surf trip amazing. I don't know of any other company that would go to that level of service for their customer!

We had a huge surprise for our kids planned for that Thursday, Ashley Kidd was coming on our boat to teach lessons all afternoon!

So huge thanks to Joe and Jeff at Performance and Justin at Tige HQ for making our week amazing.

AshleyKiddandFam.jpg