Results 1 to 8 of 8

Thread: WS-420 BT with OEM stereo?

  1. #1
    Join Date
    Jul 2018
    Location
    Central Texas
    Posts
    16
    Boat
    2019 ZX1

    WS-420 BT with OEM stereo?

    2019 ZX1 with factory DSP amps (replaced after the amp recall from wetsounds) with two pairs of REV10's on the tower. I've mentioned this before on the forum but the factory tune on the tower speakers has way too much treble, to the point that it's just painful at reasonable volumes for a surfer or wakeboarder. Our solution has been to use the equalizer on my phone and dial the treble way back which makes the tower sound great, but then the cabin speakers lack a ton of treble. This winter I'm planning on adding another sub and amp (both will be wet sounds) and wondered if having the WS-420 installed could solve this issue. I'm not sure how well it would wire into the factory stereo? If it would be a good solution, is it something the dealer could do, or should it be done at a marine audio shop? All help is greatly appreciated!
    2019 ZX1 Central Texas

  2. #2
    Join Date
    Apr 2006
    Location
    Lake Wylie area, NC
    Age
    50
    Posts
    28,187
    Boat
    Back in the good ol' days a 2006 22ve
    Ive heard the ICE does not play well with additional components placed into the signal stream, so I would go with a dealer that is also a reputable installer. Although the 420 does allow for independent attenuation of the in-boats and tower zones, you will still be dealing with the hi-pass settings within the DSP amps.
    Mikes Liquid Audio: Knowledge Experience Customer Service you can trust-KICKER WetSounds ACME props FlyHigh Custom Ballast Clarion LiquidLumens LEDs Roswell Wave Deflector And More

  3. #3
    Join Date
    Jul 2018
    Location
    Central Texas
    Posts
    16
    Boat
    2019 ZX1
    It makes me a little nervous to add the 420-BT if the ICE is prone to have an issue when adding components. When the dealer first swapped out our DSP amps, it took three more trips back to the dealer to remove the feedback in the tower speakers. Which sure confirms your point..... so I won't be taking it to this dealer for the install. But if we could find a good shop to do the install, I think this would be perfect solution. And I can't help but think that if it can be wired in, then there is a way to keep the sound clean without feedback, but maybe I'm being stubborn. I think its worth a shot, as its way more cost effect then swapping the amps out for old school tunable amps. I'm also fine with staying within the hi-pass settings, I just want to dial back the upper end of the high frequencies.

    Just to clarify chpthril, when you say to go with a dealer that is also a reputable installer, I assume youre talking about a tige dealer, and not just a wet sounds dealer. Is this correct?
    2019 ZX1 Central Texas

  4. #4
    Join Date
    Apr 2006
    Location
    Lake Wylie area, NC
    Age
    50
    Posts
    28,187
    Boat
    Back in the good ol' days a 2006 22ve
    Not necessarily boat dealers, but marine audio installer with experience.
    Mikes Liquid Audio: Knowledge Experience Customer Service you can trust-KICKER WetSounds ACME props FlyHigh Custom Ballast Clarion LiquidLumens LEDs Roswell Wave Deflector And More

  5. #5
    Join Date
    Oct 2011
    Location
    Lake LBJ, Texas
    Posts
    40
    Boat
    Tige' 2013 Z3 - 3300# Ballast
    louisparker,

    What part of central Texas are you located?

  6. #6
    Join Date
    Aug 2015
    Location
    Salt Lake City, Utah
    Posts
    1,652
    Boat
    2017 RZX3, 2013 MB F24, 2000 21V
    What did you do to get rid of the feedback in the tower speakers? Mine hum like crazy when I mute the music, engine running or not. (Actually I think they hum all the time, just notice it more when I mute the music.)

  7. #7
    Join Date
    Jul 2018
    Location
    Central Texas
    Posts
    16
    Boat
    2019 ZX1
    I'm about an hour North of Austin. I'd be willing to drive pretty far to know the work would be done right.
    2019 ZX1 Central Texas

  8. #8
    Join Date
    Jul 2018
    Location
    Central Texas
    Posts
    16
    Boat
    2019 ZX1
    The dealer installed a filter and apparently refreshed the amps or computer, I'm not quite sure as the person at the dealer that explained it to me was not the one who did the work. I've recently noticed there is still a hint of white noise that is noticeable when the music is muted, but it's only out of the tower and its not to bad. Anytime I hear it and I mention it, everyone else in the boat says they can't hear it.
    2019 ZX1 Central Texas

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •