Page 1 of 2 12 LastLast
Results 1 to 15 of 29

Thread: Actuator/plate issues

  1. #1

    Actuator/plate issues

    I’ll probably be dragging to the dealer, which I’m sure is an awesome time of year to be trying to get work ! But thought I would ask here first, as I haven’t had any problems with my plates yet.

    Got out for the first weekend on the water, and had problems cleaning up my surf wake, which I never have before. I probably should have taken pics, but I didn’t think about it, at the time. Saturday, all our regular riders rode, switched to goofy, for me, and the wave wouldn’t form, pure wash, gave up and jumped on a wakeboard, at least it was only me. Yesterday, rode both sides, all good, booze cruised for a bit, refilled ballast, for a regular rider, and it was all wash.. just dumped all the weight on the right side, and listed it for him, and got a little bit of a wave for him, although it was still pretty washed.

    I tried to look at the actuator movement in dealer mode, real quick, on the ramp, but didn’t really know what I was doing. Hit “surf=“ and “left” and “right”, and the guy looking at the plates said only the center was moving.

    Any thoughts? Do those actuators go out intermittently? Can one bad actuator cause both sides to screw up, since they work against each other, I’m guessing both didn’t fail the same weekend, but I’m kind of puzzled. Is there something I should be looking at besides those??

    Thanks for any help fellas!!!


    Sent from my iPhone using Tapatalk Pro

  2. #2
    Join Date
    May 2014
    Location
    Vancouver Island, BC, Canada
    Posts
    1,427
    Boat
    2016 RZX3, 2014 R20 with taps 3
    You probably have water in the actuator causing it to not fully retract or go down all the way when under load. When ours went they only worked half of the time.
    One thing you can do is try cycling surf right and left to engage them under load.
    To check if there is water, open up the rear access and dig around for some wires with a deutsch connector, open it up and check for moisture on the plug.

  3. #3
    That was kinda what I was thinking. Is the wiring down below where the bags are, or behind the trim panel in the storage?? If you know.. thanks brotha!


    Sent from my iPhone using Tapatalk Pro

  4. #4
    Join Date
    Feb 2016
    Location
    Boise, ID
    Posts
    1,825
    If you tested surf = and make sure to have "1" selected and try to switch left and right and nothing happens actuators need replaced. Not totally sure on the 2016 RZX but just did and 18 RZX3. On that one you pull the rear round hatches in the rear lockers. Port side Deutsch was ziptied up behing blower. Stbd was ziptied together with the pair for center plate. They are a fairly easy swap if your dealer is busy.

    15057-001 is Lenco #. You can get them on Amazon.

  5. #5
    Just got off the phone with the dealer and he said the same thing. The timing is actually right, I have a pair of transom lights sitting to be installed, so I’ll do it all at once..

    Are the access panels on the bottom of the storage, or on the back wall of the storage? Mine has a rectangular access panel on the bottom, and the back wall is one big panel, with no access panel in it, but looks like it would probably come out with a few screws.

    Thanks for the info bros!!!


    Sent from my iPhone using Tapatalk Pro

  6. #6
    Join Date
    Oct 2018
    Location
    Parker, TX
    Posts
    82
    Boat
    Tige R23
    So would this be an item/issue that is covered under warranty?


    Sent from my iPhone using Tapatalk

  7. #7
    Join Date
    May 2014
    Location
    Vancouver Island, BC, Canada
    Posts
    1,427
    Boat
    2016 RZX3, 2014 R20 with taps 3
    Yes warranty item. Back in 2017 when they had major problems I know of people who went through 5 plus sets. Even if they still work a bit they can go bad and work at times.

    There should be a round access hatch on the rear wall where the pnp bags are.

  8. #8
    Yeah, they’ll be warrantied, I have actually been surprised that I haven’t had any problems with them yet, just because, for a minute it seemed like everyone was.

    Ahhhhh... so the round panel is on the back behind the bags, under the storage, if I understood that right? The back wall on my storage panel doesn’t have any access..


    Sent from my iPhone using Tapatalk Pro

  9. #9
    Join Date
    May 2014
    Location
    Vancouver Island, BC, Canada
    Posts
    1,427
    Boat
    2016 RZX3, 2014 R20 with taps 3

  10. #10

    Actuator/plate issues

    Is that your PnP?


    Sent from my iPhone using Tapatalk Pro

  11. #11
    Join Date
    May 2014
    Location
    Vancouver Island, BC, Canada
    Posts
    1,427
    Boat
    2016 RZX3, 2014 R20 with taps 3
    Yes it is.

  12. #12
    Huh, that means I don’t have a round cutout in that panel. Hopefully it isn’t a huge PIA to pull the whole panel out.


    Sent from my iPhone using Tapatalk Pro

  13. #13
    Join Date
    Feb 2016
    Location
    Boise, ID
    Posts
    1,825
    Ya, I had a feeling the earlier RZXs didnt get the access hatch. Should be able to get them out. Theres probably one PITA screw that can only be accessed from subfloor bag area.

    BTW nice White Claws. For the ladies right? Hate to admit it but they arent bad.

  14. #14
    Sorry to hi-jack, but what was the code to put into dealer mode? I have a '19 RZX3 and you guys got me wanting to check mine now to make sure they're working properly

  15. #15
    The code on mine is 9191, think it’s the same for everything, as I found that code on here, somewhere.


    Sent from my iPhone using Tapatalk Pro

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •