Results 1 to 9 of 9

Thread: MEFI Port on 2006 Marine Power

  1. #1
    Join Date
    Jun 2015
    Location
    Phoenix
    Posts
    186
    Boat
    2006 24Ve

    MEFI Port on 2006 Marine Power

    This should be easy to find, but I can’t seem to locate the mefi diagnostic port on my 06 24ve. Seems like all connectors I could plug into already have something plugged in. I thought it would be simple to locate like the OBD port in a car, but I can’t seem to locate. Anyone know where I plug in?

  2. #2
    Join Date
    Feb 2016
    Location
    Boise, ID
    Posts
    1,643
    Dont have any MPs in for service but its a square plug on the engine. Its black, probably 10 or 12 pin plug(so ya its more rectangular). Looks kind of like this
    Attached Images Attached Images

  3. #3
    Join Date
    Jul 2010
    Posts
    4,055
    Boat
    2009 24Ve w/ AutoWake, WakeTouch, and Ultra-Ballast
    IIRC 2006 was the "transition year" for MEFI/CAN, meaning some boat engines had it and some didn't. I'm told by 2007 you could reliably presume MEFI/CAN was on all new engines. This is one reason we set a baseline year of 2007 for the R&D boat we're looking for, we must have MEFI/CAN. In other words, are you certain your 2006 engine DOES have MEFI and thus a CAN diagnostic connector?

  4. #4
    Join Date
    Jun 2015
    Location
    Phoenix
    Posts
    186
    Boat
    2006 24Ve
    Yes I am certain it has MEFI. Just can’t find the diagnostic connector. It is typically up on top of block or is it mysteriously hanging out somewhere else?

  5. #5
    Join Date
    Feb 2016
    Location
    Boise, ID
    Posts
    1,643
    Boone, I cant recall offhand where you find it on the engine. If you dont find it I will go find it on the used boat we have innour inventory on Monday for ya

  6. #6
    Join Date
    Jun 2015
    Location
    Phoenix
    Posts
    186
    Boat
    2006 24Ve
    Thanks freeheel. I appreciate it!!

  7. #7
    Join Date
    Feb 2016
    Location
    Boise, ID
    Posts
    1,643
    Boone, this probably isnt going to help because this boat is an 08 22ve with MP340. Pretty sure its got a newer MEFI 4 or 5 ECM (three plugs and big aluminum case with cooling fins). It has the newer style connector. Prettu sure yours is the older more square plug for older versions of MEFI.

    Plug was on stbd rear of motor kind of near distributor. I think you are different tho
    Attached Images Attached Images

  8. #8
    Join Date
    Jun 2015
    Location
    Phoenix
    Posts
    186
    Boat
    2006 24Ve
    Thanks for posting. I’ll keep looking. Did it have a cover/cap over the end? I’ve been looking up top primarily by the ECM. I’ll take a look deeper. From what I can tell it was just clipped into a dummy slot to keep it protected??

  9. #9
    Join Date
    Feb 2016
    Location
    Boise, ID
    Posts
    1,643
    Yes, they usually have an empty plug and a cover cap.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •