Results 1 to 11 of 11

Thread: Anybody know what this thing is?

  1. #1
    Join Date
    Sep 2014
    Location
    Lethbridge, AB, Canada
    Posts
    218
    Boat
    2008 Z1

    Anybody know what this thing is?

    While rooting around under my dash trying to get my Taps gauge to work I came across this thing. It was very near the trim tab module on my 08 Z1. Any ideas? There are two wires going into it.

    20180807_163643.jpg
    Last edited by Jetter; 08-07-2018 at 11:47 PM.
    2008 Tige Z1 Limited Ronix Edition
    360 hp, Fly High ballast, Alpine, JL Audio, Kicker, Wetsounds audio

  2. #2
    Join Date
    Apr 2006
    Location
    Lake Wylie area, NC
    Age
    49
    Posts
    27,360
    Boat
    Back in the good ol' days a 2006 22ve
    air temp
    Mikes Liquid Audio: Knowledge Experience Customer Service you can trust-KICKER WetSounds ACME props FlyHigh Custom Ballast Clarion LiquidLumens LEDs Roswell Wave Deflector And More

  3. #3
    Join Date
    Sep 2014
    Location
    Lethbridge, AB, Canada
    Posts
    218
    Boat
    2008 Z1
    Quote Originally Posted by chpthril View Post
    air temp
    That's what I thought yet I cannot get the gauges to show air temp or water temp. I have tried the procedure in the manual as shown below but it doesn't work. My gauge cluster is not like any of the ones in the manual either which is frustrating. The only things I can get it to show are the engine temperature, oil pressure and one other thing (can't remember what) on the tach and the cruise control info on the speedo. I'll take a photo next time I go by my boat.

    Capture.JPG
    2008 Tige Z1 Limited Ronix Edition
    360 hp, Fly High ballast, Alpine, JL Audio, Kicker, Wetsounds audio

  4. #4
    Join Date
    Apr 2006
    Location
    Lake Wylie area, NC
    Age
    49
    Posts
    27,360
    Boat
    Back in the good ol' days a 2006 22ve
    Theres 3 08 z1 listed on only inboards and the two with lots of pics both have the Medallion multi gauges and should show. Post a pic of your if its not like those listed
    Mikes Liquid Audio: Knowledge Experience Customer Service you can trust-KICKER WetSounds ACME props FlyHigh Custom Ballast Clarion LiquidLumens LEDs Roswell Wave Deflector And More

  5. #5
    Join Date
    Sep 2014
    Location
    Lethbridge, AB, Canada
    Posts
    218
    Boat
    2008 Z1
    The blue and yellow one in Alabama is identical to mine other than it looks like they changed the drivers seat. This is a photo of his gauges which are what mine are like.

    5358218.jpg
    2008 Tige Z1 Limited Ronix Edition
    360 hp, Fly High ballast, Alpine, JL Audio, Kicker, Wetsounds audio

  6. #6
    Join Date
    Apr 2006
    Location
    Lake Wylie area, NC
    Age
    49
    Posts
    27,360
    Boat
    Back in the good ol' days a 2006 22ve
    I cant remember which one displays the air but IIRC, the air water and depth were on the same one. Which one displays the depth.
    Mikes Liquid Audio: Knowledge Experience Customer Service you can trust-KICKER WetSounds ACME props FlyHigh Custom Ballast Clarion LiquidLumens LEDs Roswell Wave Deflector And More

  7. #7
    Join Date
    May 2016
    Location
    Amarillo TX
    Posts
    6
    Boat
    2008 Z1


    Here is my 08 Z1. Depth is at 340 sitting on the trailer at the house. I have never seen air or water temp just engine temp. My up/down buttons on the speed set don’t work so idk if you can toggle between different readings or not. I’m assuming your gages are just like mine?


    Sent from my iPhone using Tapatalk

  8. #8
    Join Date
    Sep 2014
    Location
    Lethbridge, AB, Canada
    Posts
    218
    Boat
    2008 Z1
    Quote Originally Posted by CodyBarrett View Post


    Here is my 08 Z1. Depth is at 340 sitting on the trailer at the house. I have never seen air or water temp just engine temp. My up/down buttons on the speed set don’t work so idk if you can toggle between different readings or not. I’m assuming your gages are just like mine?


    Sent from my iPhone using Tapatalk
    Exactly like mine. Bugs me to no end I don't have water temp. Now that I found this air temp sensor hanging under my dash it leads me to think that it may be possible. My speedset buttons all work for the cruise but don't do anything to change the display on the gauges.
    2008 Tige Z1 Limited Ronix Edition
    360 hp, Fly High ballast, Alpine, JL Audio, Kicker, Wetsounds audio

  9. #9
    Join Date
    Feb 2016
    Location
    Boise, ID
    Posts
    1,318
    Quote Originally Posted by Jetter View Post
    Exactly like mine. Bugs me to no end I don't have water temp. Now that I found this air temp sensor hanging under my dash it leads me to think that it may be possible. My speedset buttons all work for the cruise but don't do anything to change the display on the gauges.
    https://www.walmart.com/ip/8-Penguin...&wl13=&veh=sem

    ^^Always works and stores in the glovebox. Just out of curiosity as a tech, why does it bug you to not know water temp?? I have this complaint from a handful of people, not even that temp doesnt work but that it reads a few degrees off. I never care because I'm either getting in the water or I'm not. If I'm getting in then the water is what it is. Just trying to get some rationale from someone that is irked by it. Thanks in advance.

  10. #10
    Join Date
    Sep 2014
    Location
    Lethbridge, AB, Canada
    Posts
    218
    Boat
    2008 Z1
    Quote Originally Posted by freeheel4life View Post
    https://www.walmart.com/ip/8-Penguin...&wl13=&veh=sem

    ^^Always works and stores in the glovebox. Just out of curiosity as a tech, why does it bug you to not know water temp?? I have this complaint from a handful of people, not even that temp doesnt work but that it reads a few degrees off. I never care because I'm either getting in the water or I'm not. If I'm getting in then the water is what it is. Just trying to get some rationale from someone that is irked by it. Thanks in advance.
    I actually have a digital aquarium thermometer that I dunk in the lake if I want to know temp. Bugs me that all other Z1's, 24Vs, VEs, etc.. are all capable of showing these things and mine doesn't! Especially when I see the temp sensor hanging there with wires attached to it going into computer. Why won't my gauges show it?
    2008 Tige Z1 Limited Ronix Edition
    360 hp, Fly High ballast, Alpine, JL Audio, Kicker, Wetsounds audio

  11. Hmm, we have a 2007 22VE with the same gauges, we replaced the bezels recently we have the same piece behind our dash this is our read out


    Sent from my iPhone using Tapatalk

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •