Results 1 to 12 of 12

Thread: Bluetooth connection help

  1. Bluetooth connection help

    I need some help figuring this one out. Yesterday was the maiden voyage for our 2017 RZ2 with Tige touch. I assume that you can only have a specific number of devices paired via Bluetooth. The dealer had several devices connected. I tried to remove these devices from my system but they never cleared from the display. I could find the system showing up on my phone but everyone I tried to pair it would fail.

    Am I missing something? Does anyone know a work around?

  2. #2
    Join Date
    Feb 2016
    Location
    Boise, ID
    Posts
    1,318
    There was a software update that addresses that issue (phones not clearing from BT menu). Sound like you may need the update. I would try to clear them then shut screen off, shut master switch off then turn everything back on and see if they are gone.
    Screen usually sends a pairing request to your phone. Sounds like if that doesn't work you are stuck running aux cord or USB until you get the update.

  3. #3
    Quote Originally Posted by freeheel4life View Post
    There was a software update that addresses that issue (phones not clearing from BT menu). Sound like you may need the update. I would try to clear them then shut screen off, shut master switch off then turn everything back on and see if they are gone.
    Screen usually sends a pairing request to your phone. Sounds like if that doesn't work you are stuck running aux cord or USB until you get the update.
    My BT is a bit wonky on my 2018 as well.

    Dealer have to do the sw update or can I manually do it?

  4. #4
    Join Date
    Feb 2016
    Location
    Boise, ID
    Posts
    1,318
    It's easy enough to do yourself. I have had issues with thumb drives though. For some reason only certain brands of thumb drives will work. Beyond that it's just getting the software from your dealer or Tige. I would talk to your dealer and see if they could email it to you and give you the update procudure.

  5. #5
    Quote Originally Posted by freeheel4life View Post
    It's easy enough to do yourself. I have had issues with thumb drives though. For some reason only certain brands of thumb drives will work. Beyond that it's just getting the software from your dealer or Tige. I would talk to your dealer and see if they could email it to you and give you the update procudure.
    Thanks.

  6. #6
    I have same problem with new to me 2017 Z3. Does anybody have the latest update they can email to me?
    Last edited by Torch; 05-16-2018 at 02:14 PM.

  7. #7
    Join Date
    Mar 2018
    Location
    Jamestown, KY
    Posts
    8
    Boat
    2018 R23
    Had the exact same problem with my 2018. I emailed justin@tige.com and he sent me his link and I did it myself last night. Very easy.


    Sent from my iPhone using Tapatalk
    2018 R23, Lake Cumberland KY

  8. #8
    Thank you!

  9. i having the same problem. what specific thumb drive works I've used three of them?

  10. what thumb drive do you suggest using I've used three

  11. #11
    Join Date
    Aug 2015
    Location
    Salt Lake City, Utah
    Posts
    1,215
    Boat
    2017 RZX3, 2013 MB F24, 2000 21V
    Speaking of BT, seems the range is pretty bad. If I’m listening to music from my iPhone and take it to the back seat of the boat it breaks up really bad. Then I’ll walk back to the helm and it perfectly clear again. Is that normal? Would be a phone issue or Tige issue?

  12. #12
    Join Date
    Feb 2016
    Location
    Boise, ID
    Posts
    1,318
    I use PNY brand thumb drives.

    There was an update that helped with unpairing/forgetting old bluetooth devices and some other BT issues. I'm not sure if it helped with range st all. I am not sure but I think the BT receiver is built into the ICE module.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •