Results 1 to 9 of 9

Thread: 2007 RZ2 overloaded / limp mode?

  1. #1
    Join Date
    Jul 2011
    Location
    Salt Lake City
    Posts
    95
    Boat
    2007 RZ2 MP 340

    2007 RZ2 overloaded / limp mode?

    I have an rx2 that seems to go into a "limp" mode when it is overloaded while surfing. It only happens when I have maxed out my ballast and have more than 6 adults in the boat while surfing -- rub rail touches the water with about 3 or 4 adults sitting where ever they want. It also happened when I weighted the boat evenly, ballast full both sides and put on a suck gate (both rubrails were very close to the water) Disclaimer, I have a ballast system that is probably bigger than most. I modified the rear of my boat a bunch to allow for some huge custom sacs. I moved all the panels in the back to make more room and moved the two batteries to the rear of the motor. My rear panel is probably 6 inches from the transom, the motor panels are almost touching the motor, and the front ones by the fuel lines are moved as much as I could. The sacs also go really far up under the seats -- I took out the cooler behind the driver, and the port sack extends further. My front sacs are 400's and I usually run with both of them full.

    So, for the limp mode: The boat comes up to rpm (1235 acme prop Marine Power 340hp motor), runs for a minute or so while surfing and then goes to idle. I surf at 6k feet, 11-12mph, 2800-2900rpm, 1:1.5 tranny, and the boat isn't overheated. If I turn the motor off, it will restart and be just fine. If I reduce weight, it's just fine. Anyone know what's going on? Thanks in advance.
    Last edited by bigskymudflaps; 04-30-2018 at 05:25 AM.
    2007 RZ2 Marine power 340hp Custom ballast
    Tundra Crewmax 5.7L

  2. #2
    Join Date
    Mar 2016
    Posts
    362
    Boat
    Tigé
    Any codes thrown?
    My first thought is fuel volume such as a fuel restriction. Check fuel pressure as a starting point then look into the low pressure fuel pump. Maybe it begins to run lean then goes to limp mode. This is just a complete guess. Hopefully others can help.

    Could also be a knocking issue but I would expect it to keep retarding timing until the issue corrects itself and not go into limp mode. Does the boat do this with super unleaded?

    If it was shifter related I would think it would do this all the time.
    It's dangerous to go alone! Take this.

  3. #3
    Join Date
    Sep 2008
    Location
    Helena,MT.
    Posts
    907
    Boat
    2017 RZX2 fully custom
    When I had my first Tige 21i it would do the same thing and we found that the paddle wheel was cracked so fixed that and what we determined was the oil would be at the back of the pan and the sensor would read low when ballasted heavy so I ended up putting 1/2 a qt more in it and the issue never came back just a thought
    surf till u die.

  4. #4
    Join Date
    Mar 2016
    Posts
    362
    Boat
    Tigé
    That's a very good point 18C.
    It's dangerous to go alone! Take this.

  5. #5
    Join Date
    Aug 2010
    Location
    Long Beach, CA
    Age
    43
    Posts
    1,019
    Boat
    2015 Z3, 1999 2100i
    Probably the trans temperature switch. Shoot it with a laser thermometer but the solution would be a larger cooler to cool the fluid better. They won't throw a code but will cause it to limp.
    Fixing everyone elses boat just so I can use mine...

  6. #6
    Join Date
    May 2015
    Location
    AB, Canada
    Posts
    234
    Boat
    2006 22VE
    Just throwing out ideas here. This is similar if not exactly what 18C said.

    I had a serious loss of power while I was listed a few times last year, the boat would just lose all power and nearly die. Not limp mode like your describing though. When the boat was level the oil level was good, although maybe on the lower half of the normal range. Never had the issue when the boat was level. Long story short, even with the oil level in the normal range, when the boat was listed it caused some issues with the engine thinking it was low on oil. I added a quart and all my troubles went away, and now I make sure the oil level is on the upper half of the normal range, hasn't done it since.

    I'm not sure whats causing your issue, but check your oil level and top it off, it could be something as simple as that.

  7. #7
    Join Date
    Jul 2011
    Location
    Salt Lake City
    Posts
    95
    Boat
    2007 RZ2 MP 340
    Great ideas. Trans temp: Good theory, but it did this when completely cold. I filled up all my sacs at the dock after it sat over night. I then put a suck gate style device on the side (a homemade one that is pretty big -- lots of drag). I pulled the boat out of the dock, someone jumped in the water and away we went. The motor was struggling, the boat had tons of weight. About 200 yards later, the boat went into limp mode.

    Angle of the boat: It happened, as noted above, with the boat weighted evenly and not much bow rise (the bow had almost 800lbs in it).

    Fuel restriction: A very viable theory.

    Unleaded gas: I always use 90 octane. I don't have access to anything more unless I put in an additive.

    Fixes: I'm going to make sure the oil is where it is supposed to be and see if my mechanic can check out the fuel system. It's a 10 year old boat and I don't think we have changed out the filters or had the pump checked.

    Thanks for all the help folks. Sometimes there is something really quirky with these boats -- a while ago I had the power wire fall off my fuel pump. Super simple fix, could have been a disaster, as it happened on the first day of a week long vacation. I called a dealer and within a minute we had it going -- priceless help.
    2007 RZ2 Marine power 340hp Custom ballast
    Tundra Crewmax 5.7L

  8. #8
    Join Date
    Jan 2011
    Location
    Grand Lake, Oklahoma
    Age
    59
    Posts
    4,966
    Boat
    2007 24ve
    Check that wire again as my boat had similar problems for a long time. Turned out to be "that" wire.

    Also I must say that is a huge amount of wieght with a 340 HP engine at altitude. Impressed you can get it to move. What lake are you going to?
    Wake Up or Stay On Shore!

  9. #9
    Join Date
    Jul 2011
    Location
    Salt Lake City
    Posts
    95
    Boat
    2007 RZ2 MP 340
    Don’t tell anybody—- Hebgen lake. Beautiful place. I’ll check the wire again. The person who put that lousy connection on the bottom of the pump needs to design useless stuff — maybe the tubes kids like to get pulled on behind boats....
    2007 RZ2 Marine power 340hp Custom ballast
    Tundra Crewmax 5.7L

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •