Results 1 to 6 of 6

Thread: Wet Sounds 420 BT Question

  1. #1
    Join Date
    Mar 2018
    Location
    Austin TX
    Posts
    11
    Boat
    2005 Tige 22v Riders Edition

    Wet Sounds 420 BT Question

    I just installed a new WS 420 BT. I completely removed the old receiver so I am using the WS420bt as my head unit. The problem is the blue tooth input does not work at all. I have tried 3 different phones and none of them even see or recognize the ws420bt. The input switch is set to "BT". Any suggestions?

  2. #2
    Join Date
    Apr 2006
    Location
    Lake Wylie area, NC
    Age
    49
    Posts
    26,896
    Boat
    Back in the good ol' days a 2006 22ve
    I always like to suggest your wet sounds dealer as being a front line resource for questions and concerns.

    With that said, is the phone(s) "seeing" the WS-420? If seeing it, but fails to connect? or shows to pair/connect yet you dont get any output?

    What about using a 3.5MM cable between the phone or other MP3 and the 420's AUX input with the source dial to AUX? does everything work normal then?
    Mikes Liquid Audio: Knowledge Experience and Customer Service you can trust-KICKER WetSounds ACME props ARC Audio FlyHigh Custom Ballast Clarion LifeForm LED Polk Rockford And More

  3. #3
    Join Date
    Mar 2018
    Location
    Austin TX
    Posts
    11
    Boat
    2005 Tige 22v Riders Edition
    Yes sir, the aux input works. When you select "bt" on the input dial the phone does not see the "WS420" at all. I tried 3 different phones with no luck.

  4. #4
    Join Date
    Apr 2006
    Location
    Lake Wylie area, NC
    Age
    49
    Posts
    26,896
    Boat
    Back in the good ol' days a 2006 22ve
    Pull the inline fuse for the WS420BT to power cycle it. Wait a minute and plug fuse back in and see.
    Mikes Liquid Audio: Knowledge Experience and Customer Service you can trust-KICKER WetSounds ACME props ARC Audio FlyHigh Custom Ballast Clarion LifeForm LED Polk Rockford And More

  5. #5
    IIRC your phone won’t show “ws-420” as a Bluetooth source. I think my old one was something weird like trk.... or something like that where you couldn’t tell it was the 420.


    Sent from my iPhone using Tapatalk

  6. #6
    Join Date
    Apr 2006
    Location
    Lake Wylie area, NC
    Age
    49
    Posts
    26,896
    Boat
    Back in the good ol' days a 2006 22ve
    The Wet Sounds 420BT and 220BT do actually show on the phones as such. Their universal BTs also show up as WW-BT
    Mikes Liquid Audio: Knowledge Experience and Customer Service you can trust-KICKER WetSounds ACME props ARC Audio FlyHigh Custom Ballast Clarion LifeForm LED Polk Rockford And More

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •