Page 1 of 2 12 LastLast
Results 1 to 15 of 17

Thread: Looking for Faria SJ0013 gauge

Hybrid View

  1. #1

    Looking for Faria SJ0013 gauge

    My Speedometer is failing and when I tried to send it back to Faria for a rebuild, they told me it is obsolete and there is no replacement. The part number is SJ0013. I have a 2006 24Ve that uses a paddle wheel for for the speed. Anybody have any ideas of where I might be able to find a replacement? It also reads depth, water temp and air temp from a small digital screen in the same gauge. Those features still work as does my speed set. I emailed Tige and never heard back (anytime I have ever emailed them). Faria just said tough luck. Thanks in advance!

  2. #2
    Join Date
    Dec 2015
    Posts
    74
    Boat
    2005 Tige 22i
    Is it just the speedo that does not work but everything else works? If so then I would look into NauticLogic GPS based system that plugs right in. My speedo stopped working with the paddlewheel, but Nauticlogic fixed that.

  3. #3
    Everything else is working. Unfortunately Tige went to a drive by wire system in 06 and I can't use anything except the Tige Speedset....

  4. #4
    Join Date
    Dec 2015
    Posts
    74
    Boat
    2005 Tige 22i
    Nauticlogic list 2006 as compatible with the following: http://nauticlaugic.com/NL4-Fc_2017_Packages.html That is the same package I installed in my boat. It plugs inline with the connectors on the speedo and drops the paddlewheel signal and replaces it with the GPS signal. However you may want to call them and see what they say.

  5. #5
    Quote Originally Posted by h2o-ski View Post
    Nauticlogic list 2006 as compatible with the following: http://nauticlaugic.com/NL4-Fc_2017_Packages.html That is the same package I installed in my boat. It plugs inline with the connectors on the speedo and drops the paddlewheel signal and replaces it with the GPS signal. However you may want to call them and see what they say.
    I'll look into it! Thank you. Tige made the switch to drive by wire about halfway through 2006 production year, so there are some 2006's out there without DBW.

  6. #6
    Join Date
    Dec 2015
    Posts
    74
    Boat
    2005 Tige 22i
    Quote Originally Posted by efrickle View Post
    I'll look into it! Thank you. Tige made the switch to drive by wire about halfway through 2006 production year, so there are some 2006's out there without DBW.
    The GPS unit only plugs into the speedo and should not care about DBW or DBC.

  7. #7
    Join Date
    Apr 2006
    Location
    Lake Wylie area, NC
    Age
    49
    Posts
    26,658
    Boat
    Back in the good ol' days a 2006 22ve
    Bummer, no repair option of refurb available?
    Mikes Liquid Audio: Knowledge Experience and Customer Service you can trust-KICKER WetSounds ACME props ARC Audio FlyHigh Custom Ballast Clarion LifeForm LED Polk Rockford And More

  8. #8
    Nothing from Faria. I am hoping someone that is far smarter than me has figured out something that will work.

  9. #9
    Join Date
    Jan 2004
    Location
    Mount Juliet, TN
    Posts
    2,440
    Boat
    Any
    Can they not rebuild or repair the gauge for you?

  10. #10
    No, they said it is obsolete and I guess all they did was replace the board. They are out of boards.

  11. #11
    Update: Justin at Tige is currently helping me find a solution. I will post another update as soon as I have it!

  12. #12
    Join Date
    Apr 2006
    Location
    Lake Wylie area, NC
    Age
    49
    Posts
    26,658
    Boat
    Back in the good ol' days a 2006 22ve
    So what if you have a bad speedo, as is the case here with Eric? Going from paddle wheel to GPS makes not different, you still have an analog speedo head that wont show speed.

    Also, an 06V could still have the cable driven MP engine and perfect pass, but a Ve would have had the new DBW MP engine and ACCU-SET. Yes, I know there are a couple rare early ve boats with PP, just stating it as it was by the year/model break, not an absolute on 100% of the models.
    Mikes Liquid Audio: Knowledge Experience and Customer Service you can trust-KICKER WetSounds ACME props ARC Audio FlyHigh Custom Ballast Clarion LifeForm LED Polk Rockford And More

  13. #13
    Quote Originally Posted by chpthril View Post
    So what if you have a bad speedo, as is the case here with Eric? Going from paddle wheel to GPS makes not different, you still have an analog speedo head that wont show speed.

    Also, an 06V could still have the cable driven MP engine and perfect pass, but a Ve would have had the new DBW MP engine and ACCU-SET. Yes, I know there are a couple rare early ve boats with PP, just stating it as it was by the year/model break, not an absolute on 100% of the models.
    Thanks Mike! The problem I am running into is that I would have to purchase a GPS speedo to fill the 4" void where the multifunction gauge is and then add a new gauge somewhere for depth & temp. Faria and Tige aren't sure I can use the existing triducer sensors. I also have to leave the paddlewheel or my speedset won't work. Thanks for the clarification on the 06 models.

  14. #14
    Join Date
    Dec 2015
    Posts
    74
    Boat
    2005 Tige 22i
    Quote Originally Posted by chpthril View Post
    So what if you have a bad speedo, as is the case here with Eric? Going from paddle wheel to GPS makes not different, you still have an analog speedo head that wont show speed.
    That is a possibility as there could be a number of reason why it is not registering speed. For my case the speedo was not registering speed but all other functions worked and the water temp and depth sounder still worked which for me meant that the triducer was still somewhat functioning. Adding the NauticLogic unit fixed the issue as for me the paddlewheel function of the triducer was not working.

  15. #15
    Join Date
    Mar 2016
    Posts
    171
    Boat
    Tigé
    Quote Originally Posted by h2o-ski View Post
    That is a possibility as there could be a number of reason why it is not registering speed. For my case the speedo was not registering speed but all other functions worked and the water temp and depth sounder still worked which for me meant that the triducer was still somewhat functioning. Adding the NauticLogic unit fixed the issue as for me the paddlewheel function of the triducer was not working.
    The green wire splits at the triducer. Be sure you have continuity from the triducer plug to the gauge. Maybe its just lost its connection and the gauge is still good.
    It's dangerous to go alone! Take this.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •